BBeaoeHue B A3bik C

*3Hakomecmeo ¢ uHmezpuposaHHou cpedou Visual C.
*Co30aHue nepeoao rnpoekma.
*[lpoepamma «lMpusem Mup!».
*MaHunynssmopel ebigoda.
*YnpaxHeHus.

*[lepemeHH:bIe.
*OrnucaHue rnepemMeHHbIX. Turbl NepeMeHHbIX.
*BB00 rnepemMeHHbIX ¢ Krnasuamyphbl U 8bI800 UX Ha 3KPaH.




3HaKOMCTBO C UHTerpupoBaHHou cpegom Visual C.
Co3gaHne npoekTa.

File > New > Project...

New Project ? n

P Recent .NET Framework 4.5 ~ Sort by: Default | El Search Installed Te P ~
4 |nstalled o 5 ey
h Win32 Console Application ~ Visual C++ Type: Visual C++
ES
4 Templates A project for creating a Win32 console
: iy ; : : application
4 Visual C++ Win32 Project Visual C++ PP

Windows Store

ATL

CLR

General

MFC

Test

Win32

Windows Phone

LightSwitch
v

b Online
Name: [name_project] |
Location: D:\®W eawa nanka c npoexkTamu’, v
Solution name: name_project Create directory for solution

Add to source control

’ oK ‘ I Cancel

Name: - Iima bygywiero npoekra.
Location: - PacnonoxeHne npoekTa.
Solution Name: - ims cbopku.




3HaKOMCTBO C MHTerpuposaHHomn cpegou Visual C.

Win32 Application Wizard - project_01 > IEE

D Welcome to the Win32 Application Wizard

e ae These are the current project settings:

Appiication Settings e Console application

Click Finish from any window to accept the current settings.

After you create the project, see the project's readme. txt file for information about the
project features and files that are generated.

| Next > || Finish H Cancel




[MocTasbTe ranoydky HanpoTuse nyHkTa Empty project (nycton npoekT)

Win32 Application Wizard - project_01

=3 Application Settings
C\_

Overview Application type: Add common header files for:

Applcation Settings () Windows application
(®) Console application
Obu
() Static library

Additional options:
Empty project

«| Precompiled heade

Security Development Lifecyde (SDL)
checks

< Previous

: I

Finish

Cancel

Haxxmute kHonky Finish




Haxmunte kHornky Cancel

Connect to Team Foundation Server

Select a Team Foundation Server:

|

Servers...

Team Project Collections:

Team Projects:

Project Collections

@) Select a Team Foundation Server to view Team

Connect

Cancel




DC project_01 - Microsoft Visual Studio

FILE

EDIT  VIEW

PROJECT

New

Open
Add
Close Solution

Save project_01

ave Selected tems

Save All

Export Template...

Source Control

Print...

Recent Files

Recent Projects and Solutions

Exit

BUILD

Ctrl+S

Ctrl+Shift+S

Alt+F4

DEBUG

»

TEAM

3
®

SQL TOOLS  TEST

Project...
Web Site...

Team Project...

B

File...

Project From Existing Code...

ARCHITECTURE

Ctrl+Shift+N
Shift+Alt+N

Ctrl+N

HaxaTtb File > New > File...(MoxHoO Tak Ctrl+N)

ANALYZE

-

WINDOW
Win32

-

HELP
A



Bbibpatb a3bIk Visual C++ > C++ File(.cpp) > Open

4 |nstalled

General

Performance
b Web

Script

Graphics

Sort by: Default

++
D C++ File (.cpp)

E-ﬁ'

Header File (.h)

New File

Visual C++

Visual C++

-.»
Search Installed Templates (Ctrl+E) P~

Type: Visual C++

Creates a file containing C++ source code

l Open I'|| Cancel




Mpukpenntb doann k npoekty File > Move Sourse1.cpp > 1 name_project

Da name_project - Microsoft Visual Studio
FILE |[EDIT VIEW PROJECT BUILD DEBUG TEAM SQL TOOLS TEST AR

New * | Windows Debugger ~ Auto
Open 4

Add ’

Close

B3 Close Selution

B Save Sourcel.cpp Ctrl+S
Save Sourcel.cpp As...

Advanced Save Options...

W SaveAll Ctrl+ Shift+S
Export Template...
Source Control »
B Page Setup...
@ Print... Ctrl+P
Recent Files »
Recent Projects and Solutions 4
Move Sourcel.cpp into » | 1 name_project

B Exit Alt+F4 |




HaxaTb KHonky Save

© 3

i ﬂ <« OW sawa nanka c npoektamn » name_project » name_project

v? 0 ’ Mownck: name_project
Ynopsgounte ¥

Cozgate nanky

~
] Microsoft Visual Studio 2012 B Wma [lata usmerenma

Twun
B PaBouwii cton

Her 3nemeHTOB, yA0BNETBOPAOLLNX YCIOBWAM NONCKS.

& Jomawmss rpynna

m Jluctonag Onera
’ 3tot xoulhblo'rep
Bubnnotekn

. Bugeo

JokymenTel

(=] Wz06paxerua

Jl Myzbika
€ Cern

Wma daiina: | EElile

Tun daiina: |C++ Source Files (*.cc;*.cpp;™.00)

@ CKkpbITe Nanku




Ecnu Bce warn npogenaHsl BEpHO B nanke Source Files otobpasntcsa dann
C umeHem Sourcel.cpp

0 name_project - Microsoft Visual Studio
FILE EDIT VIEW PROJECT BUILD DEBUG TEAM SOL TOOLS TEST ARCHITECTURE ANALYZE WII
(R 1l - W . - P Local Windows Debugger ~ Auto ~ Debug =~ Win32

| ‘

Solution Explorer MR W Sourcel.cpp # X
N o-2ap i (Global Scope)
Search Solution Explorer (Ctrl+; P ~

fa] Solution 'name_project' (1 projec
4 [%] name_project
&3 External Dependencies
= Header Files
= Resource Files
4 &g Source Files

O Sourcel.cpp

[oToBO. NpoeKT co3naH.



3HaKOMCTBO C uHTerpuposaHHoun cpenom Visual C.

View > Solution Explorer...(Ctrl + Alt + L)

Solution Explorer O X

@ o-2d® o &
Search Solution Explorer (Ctrl+;) P~

fa] Solution 'name_project’ (1 project)
4 [%] name_project
&3 External Dependencies
= Header Files
= Resource Files
4 &3] Source Files
o Sourcel.cpp




3HaKOMCTBO C MHTerpuposaHHomn cpegou Visual C.

#include<stdio.h> I'IepBaﬂ caMad npoctasd nporpamma

#include<conio.h>

int main () //TrnaBHasg GYyHKLUMS OIPOTPAMME

{

getch () ; //byHKlUKS 3amdepXkKy SKpaHa

return 0; //coobmaer OC BHIIOJHMIIACE NPOTPaMMa YCIEWHO, JubO BaBepumiiach B
ABAPUMHOM pPexnMme

}
Komnunauma (3anyck nporpammbl):

Local Windows Deb -
P Local Windows Debugger Debug > Start Debugging ( F5 ).

[Mporpamma “INpuseTt, Mup!”

#include<stdio.h>

#include<conio.h>

int main () //TrnaBHag GYHKLUMS IPOTPAaMME
{

printf ( "Hello World!!'!™ );

getch(); //byHKUUA BamepXKu BKpaHa
return O0O;

}




3HaKOMCTBO C UHTerpuposaHHou cpegou Visual C.

[Mporpamma “INpuset, Munp!”

#include<stdio.h>
#include<conio.h>

int main ()

{

printf ( "Hello World!!!"™ );
getch () ;

return 0;

}
BbinonHeHue nporpamMmmsbl rno wwaram.

F10 — BoinonHeHune 6e3 Bxoga B OYHKLUMN.
F11 — BeinonHeHne ¢ 3axoqoM B OYHKLINMN.

#include<stdio.h>

#include<conio.h>

#include<windows.h>

int main ()

{

SetConsoleCP (1251) ;//nookiouyaeM PYCCKUM S3BIK
SetConsoleOutputCP (1251);//nonkiouyaeM PYCCKUM s3BIK
printf ("lpuseTr mMup!!!" );

getch () ;

return 0O;

}




Ecnu pyccknin TekcT He nosiBuncs, To kKnukHuTe NKM no KoHCONbHOMY OKHY, caenanTte Boblibop
Bknagkn Wpudgt >(Lucida Console) > OK

Sourcel.cpp ® X

(Global Scope)

—#includ
#includ
#includ

—-lint mai

1

SetCons
SetCons
printf(
getch()
1

J

100 % -~

Autos

®° D\OW Bawa nanki

MpueeT mup!!!

- @ main()

Ceowvictea: "D:\®WU Balua nanka ¢ npoekramu\... n

O6wwme | WpwdT | Pacnonoxerme | Lseta #X
Bua okHa Pasmep
12
2 A
| 14
|16
|18
|20
24
| 28
136 V
WpuepT [ ] KupHbiia
! l.l: Consolas :
| | Lucida Console ! i
TO4EYHbIE WpNdTEl
v
BeiBpanHbiit wpueT : Lucida Console
C:\WINDOWS> dir Pasmep 3HaKoB:
§$§TEH‘7 *B%S> WupuHa (vkcenn): 7
SYSTEM3Z2  <DIR> 1 TR i

7 0K Otvena



3HaKOMCTBO C MHTerpuposaHHomn cpegou Visual C.

[Mporpamma “INpuset, Munp!”

#include<stdio.h>

int main ()

{

printf ( "Hello World!!!™ );

getch () ;

return 0;
}

View > Qutput

Output v [ X
Show output from: Build - £ 2 | &
1> o
1>Build succeeded. =
1>

1>Time Elapsed ©0:00:01.41
========== Rebuild All: 1 succeeded, @ failed, @ skipped ==========

4 )
Output | Error List

MaHenb, oTobpaxatowasa coobleHns o npouecce
BbINOSTHEHUSA NporpamMmbl. B Tom uncne coobuweHnsa o6 owmbkax.




3HaKOMCTBO C uHTerpuposaHHoun cpenom Visual C.

View > Error List (cnmucok owmbok)

Y - |€) 2Errors I 0 Warnings D Messages Search Error List P~

Description File Line Column Project

(X)1 error C3861: 'getch": identifier not found sourcel.cpp name_project

[3 2 IntelliSense: identifier "getch” is undefined Sourcel.cpp 8 1 name_project

Output  Error List

[Mocne ncnpaeneHns oWnBOK HYXKHO caenaTtb Nnepecbopky NpoekTa:
Beibpate B MmeHto nyHKT BUILD > Rebuild Solution (Ctrl+Alt+F7).




3HaKOMCTBO C MHTerpuposaHHomn cpegou Visual C.

[Mporpamma “INpuset, Mup!”

#include<stdio.h>
#include<conio.h>
int main ()
{
printf ( "Hello World!!!™ );
getch();
return 0O;

¢ d:\Projects\HalloWorld\debug\HalloWorld.exe -

Hello World???




3HaKOMCTBO C MHTerpuposaHHomn cpegou Visual C.

MaHunynaTopbl BbiBoAa (ynpasnstoLmne CUMBOSbI)

#include<stdio.h>
#include<conio.h>
int main ()
{
printf( "Hello \nWorld!!! " );
getch () ;
return O;

cn  d:\Projects\HalloWor ld\debug\HalloWorld.exe




3HaKOMCTBO C MHTerpuposaHHomn cpegou Visual C.

MaHunynaTopbl BbiBoAa (ynpasnstoLmne CUMBOSbI)

#include<stdio.h>
#include<conio.h>
int main ()
{
printf ( "Hello \n" );
printf ( "World!!!"™ );
getch () ;
return 0O;

cn  d:\Projects\HalloWor ld\debug\HalloWorld.exe




3HaKOMCTBO C MHTerpuposaHHomn cpegou Visual C.

MaHunynaTopbl BbiBoAa (ynpasnstoLmne CUMBOSbI)

\n [lepexon Ha CJIeOywnlyl CTPOKY

\t ToprBOHTAJIbHAA Tabynaums

\r Bos3BpaT Kypcopa B HauaJio CTPOKMU
\a 3BYKOBOM CMIT'HAaJ

A\ BEIBOO CMMBOJIA HAKJIOHHOWM UYEPTH \

7

\" BEHIBOII CUMMBOJIA KaBLBIUKU




3HaKOMCTBO C MHTerpuposaHHomn cpegou Visual C.

YnpaxHeHne — HapucoBaTtb rpynmny duryp.

cv  d:\WProjects\HalloWor ld\debug\HalloWorld.exe

A BEBBBB CCCC
A A BB B
A A BEBBBBB
AAAAAAA

I

a3
Cad
tad
Cad
tad
Cad
tad

CaEakaZaZaakal

XX X X X X X

¢y d:\WProjects\HalloWor ld\debug\HalloWorld.exe

gooooooot ee ee CEEEEEEPPEE
@ e ee @
@ C ee @
@ @ e ee @
eee ee ee eeeeee




YnpaxHeHue — HapucoBaTb UrypKy KoTa.
CamocTtoaTenbHO Noa AopOoXKon cUMBONOB % % % % % %
nobaBbTe cMMBONbLHYIO Hagnuce CAT.




[lepemeHHbIe

OnucaHue nepeMeHHbIX

“ o
J

Umsi nepemeHHOU — 10boe €r1080, Ha4YuHaruweecs ¢ bykebl, Uunu 3Haka
u codepxauwee morbko uugpsbl, bykebl, u 3Hak “ 7. Umsa nepemeHHoOU He

O0O/MKHO coernadame ¢ UMeHaMmu beHKL(Ulj usiu Krilo4yesbiX CJ108.

lpumepsbi:
a, ABC, 123, num1, wary long variable _name
HeeepHble uMeHa:
1name, main, printf, else...

KaroueBbie cJioBa

case double nt struct
break else switch
t hil
char float returh while
const for sizeof do
default

continue



[lepemeHHbIe

B s3pike “C” CylmIECTBYIOT CIEAYIOIIUE THIILI AAHHBIX: JAHHBIC LIEJIOTO THIIA,
BEIIICCTBCHHBIC THUIIbl JAHHBIX, CUMBOJIbHBIE JAHHBIE, IEPEMEHHBIC MEPEUUCIIEMOTO

TUMA, CTPYKTYPHBIN THI JAHHBIX.

Tunel nepeMeHHbIX.

int - (integer) uemnas nepemeHHas, 3HavyeHus - -2, -1, 0, 1, 2
float - npobHas MnepeMeHHas, 3HadveHusa - 1.25, -354.414, 33,1416
double - OpoOHasd nepeMeHHasa YIOBOEHHOM TOUHOCTU

Ominu4ue float om double

double - sTo float ¢ JaydmeMm TOUHOCTBLIO. PasHMIla B pasMepe aMaTH, KOTopoe
BRIOEJISeTCH OO 2TUM TuUIb HaHHBX (float BaHmuMmaer 4 OGamra, double =3aHmMaeT 8 6amT) .

lNapamempsi(crieyugpukamopsbl) eeo0a/ebigoda rnepemMeHHbIX:

int - sd
float - st
double - $1f




[lepemeHHbIe

ObmbsierieHUe rnepeMeHHbIX

#include<stdio.h>
#include<conio.h>
int main ()

{

int a;

a = 5;

printf( "a = %d", a );
getch();

return 0;

}

#include<stdio.h>
#include<conio.h>
int main ()

{

b = 8;

c = a + b;

printf( "Cymma a + b sT0o: %d", c );
getch();

return 0O;




[lepemeHHbIe

ObmbsierieHuUe nepemMeHHbIX. BapuaHmel ripo2pammei.

#include<stdio.h>
#include<conio.h>
int main ()
{
int a = 5, b = 8;

int ¢ = a + b;
printf( "Sum a + b is: %d", c );
getch () ;

return 0;

#include<stdio.h>
#include<conio.h>
int main ()
{
int a = 5, b = 8;

a =a + b;
printf( "Sum a + b is: %d", a );
getch ()

return 0;

#include<stdio.h>
#include<conio.h>
int main ()

{

int a = 5;

int b = 8;

printf( "Sum a + b is: %d", a + b );
getch ()

return 0;



[lepemeHHbIe

TUﬂblﬂepeNKﬁﬂﬂﬂX

#include<stdio.h>
#include<conio.h>
int main ()
{
double a = 5.5, b = 8.1;
double ¢ = a + b;
printf( "Sum %1f + %$1f is: %S1f", a, b, c );
getch();
return O;

¢ d:\Projects\HalloWor ld\debug\HalloWorld.exe -

Sum 5.500000 + 8.100000 is: 13.600000




[lepemeHHbIe

YnpaxHeHne — 3agatb 3 4nucna a, b, ¢, 1 BbIBECTU pesynbTaTbl Bbipa)XKeHUN
a*b+c
b-c*a
a*(c—-b)
(BbIBECTM OQHOBPEMEHHO)

cv d:\Projects\HalloWor ld\debug\HalloWor ld.exe - ID

I E




[lepemeHHbIe

Bg00 rnepemMeHHbIX ¢ Knaguamypbl U 861800 UX Ha 3KpaH

#include<stdio.h>
#include<conio.h>
int main ()

{
double a, b;

printf( "Enter A : " ),
scanf ( "%1f", &a );
printf( "Enter B : " );

scanf ( "S$S1f", &b );

printf( "Sum $1f + %1f is: S$1f", a,b,atb );
getch();

return 0O;

cv  d:\Projects\HalloWor ld\debug\HalloWorld.exe

Enter A = 4.3
Enter B = —3.43
Sum 4.300000 + —-3.430000 is: 0.870000




[lepeMeHHbIe

Bg00 rnepemMeHHbIX ¢ Knaguamypbl U 861800 UX Ha 3KpaH

#include<stdio.h>
#include<conio.h>
int main ()

{

double
printf (
scanf (
printf (
getch ()
return

a, b;

"Enter A and B " );

"$1f%1£", &a, &b);

"Sum %1f + %$1f is: %1f", a,b,atb
0;

) ;

C:A\Windows\system32\cmd.exe
A and B 4.3

300000 + -3.430000 is:

-

|| 3]

0.870000_

P

C:\Windows\system32\cmd.exe

Enter A and B 4.3 —-3.43
Sum 4.300000 + —-3.430000 is: 0.870000_




[lepemeHHkle.

YnpaxHeHne — BeecTtu ¢ knaBmatypbl 3 4yucna a, b, ¢, 1 BblBECTU pe3ysibTaThbl BblpaXXeHUN
a*b+c
b-c*a
a*(c—-b)
(BbIBECTM OQHOBPEMEHHO)



YrpaxxHeHUs.

Hanuwume npozpammy, komopas npednazaem esecmu 2 OpObHbIX 3Ha4YEHUS, MOC/Ie Ye20 8bIs0OUM CYyMMY,
pasHocmb amux 08yXx 3Ha4eHuUU.

Hanuwume npozgpammy, komopasi 6600UmM ¢ Krnasuamypbl 3 Uerbix Yucna, 8bI800Um UX CyMmy,
rnpoussedeHue, cpedHee apughmemu4ecKoe.

Hanuwume npozpammy, komopasi ebisodum Keadpamabl U Kybbl yuces om 0 0o 10.

0 0 0
1 1 1
2 4 8
3 9 277
4 16 64

N mak Oarnee...



